logoПричины, побудившие перенести сайт на свой сервер вас удивят!

Хостится одно предприятие на хостинге R01.RU, нормальный такой хостинг, ничего хорошего, как и плохого, сказать не могу... с ними договор на организацию, в общем - все нормально.

Только на втором году сотрудничества дернул меня Леший обновить версию LMS Moodle c 2.6.x на 3.1.x, как оказалось Moodle 3.1.x требует PHP не ниже версии 5.4.4. Я удивленно почесал затылок и подумал: "а какая версия сейчас включена?". Оказалось - PHP 5.3! В управлении модулями я обнаружил, что мне доступны только версии 5.3, 5.2, 5.1 и 4.4, блин! 4.4.

версии php доступные в панели

рис. 1. Версии PHP доступные на хостинге

 

Связавшись с поддержкой я выяснил, что поддержка версии 5.4 планируется, уже давно, и не известно когда! Для справки, сейчас 05 ноября 2016, табличка на рис. 2 хостера вообще не напрягает)

поддерживаемые версии php

Рис. 2 Поддержка версий PHP - источник

 

Если разобраться, то нужна поддержка PHP 5.6 в любом случае. Выводы печальны - отбить "по максимуму" вложенные деньги и ликвидация...

Было принято решение - собрать простой веб сервер и перенести Moodle на него.

Продолжение следует... опишу железо, которое я нашел для "нового web-сервера", будете смеяться)

Добавить комментарий


Защитный код
Обновить